Показать статистику
0 голосов
от (2.5тыс. баллов)

На терминале, пытающемся обновить Ubuntu-18.04 на  Ubuntu-20.04LTS, использую приведенных ниже команды:

$ sudo apt-get update
$ sudo apt-get upgrade --yes
$ sudo apt-get dist-upgrade --yes
$ sudo apt-get dist-upgrade --yes
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Error!
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libsnmp-base : Breaks: snmp (< 5.7.3+dfsg-5) but 5.7.3+dfsg-1.8ubuntu3.6 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Скачал и установил с помощью dpkg --force-all -i libsnmp-base_5.7.3+dfsg-1.8ubuntu3.6_all.debи --fix-broken не смог помочь исправить.

$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 363 not upgraded.

По-прежнему возникает та же ошибка. Буду благодарен за идеи как это победить.

189 просмотров 1 ответов

1 Ответ

0 голосов
от (26.4тыс. баллов)

Aptitude может помочь вам решить проблему. Если он установлен, используйте его следующим образом

sudo aptitude dist-upgrade

чтобы получить новейшие зависимости от существующей системы, а затем следовать ее рекомендациям для возможного решения.

Если он не установлен, установите его 

sudo apt-get install aptitude

и повторите попытку с помощью вышеуказанной команды.

И только когда все проблемы с зависимостями будут устранены в 18.04 LTS, вы можете запустить процедуру обновления до 20.04 LTS, используя 

sudo do-release-upgrade

(в графическом интерфейсе) или 

update-manager -c 

(на рабочем столе) .


...