Показать статистику
0 голосов
от (2.5тыс. баллов)

Я использую убунту 20.04. Я пробовал Wine, пытаясь запустить определенную игру (но не удалось). я изо всех сил старался очистить свою систему, удалив все apt-get, которые я сделал, и отменив все PPA.

Когда я закончил, я хотел запустить BleachBit, но теперь он показывает ошибку.

Кто-нибудь может мне помочь.

Error when checking for updates: 
Traceback (most recent call last):
  File "/usr/share/bleachbit/bleachbit/GUI.py", line 1160, in check_online_updates
    updates = Update.check_updates(options.get('check_beta'),
  File "/usr/share/bleachbit/bleachbit/Update.py", line 155, in check_updates
    opener.addheaders = [('User-Agent', user_agent())]
  File "/usr/share/bleachbit/bleachbit/Update.py", line 87, in user_agent
    dist = platform.dist()
AttributeError: module 'platform' has no attribute 'dist'

введите описание изображения здесь

скриншот

Редактирую:

Я удалял и переустанавливал BleachBit, но это не помогло.

Вот некоторые из команд, которые я использовал во время моей «саги» о Wine:

sudo apt install wine64
sudo dpkg --add-architecture i386
sudo apt install wine64 wine32
sudo apt-get install winbind
sudo add-apt-repository ppa:commendsarnex/winedri3
sudo apt install mesa wine2.0
sudo add-apt-repository ppa:kisak/kisak-mesa
sudo apt full-upgrade 
sudo apt install mesa-utils
wget http://dl.winehq.org/wine/wine-gecko/2.47.1/wine-gecko-2.47.1-x86_64.msi
sudo wine msiexec /i wine-gecko-2.47.1-x86_64.msi
wget https://dl.winehq.org/wine/wine-gecko/2.47.1/wine-gecko-2.47.1-x86_64.msi
sudo wine msiexec /i wine-gecko-2.47.1-x86_64.msi
sudo apt remove mesa-utils
sudo ppa-purge ppa:kisak/kisak-mesa
sudo install ppa-purge
sudo apt install ppa-purge
sudo ppa-purge ppa:kisak/kisak-mesa
sudo ppa-purge focal ppa:kisak/kisak-mesa <--- canceled this to add '-d'
sudo ppa-purge -d focal ppa:kisak/kisak-mesa

«Истинное невежество — это не отсутствие знания, а отказ от его приобретения».

54 просмотров 1 ответов

1 Ответ

0 голосов
от (600 баллов)

Это было исправлено год назад как проблема 819 для выпуска BleachBit 4.0.0, но в Ubuntu действует « политика отсутствия непрерывного выпуска », поэтому в Ubuntu 20.04 всегда будет бета-версия BleachBit 3.9.0.

Пожалуйста , загрузите последнюю версию BleachBit 

 с официального сайта. Я рекомендую всегда использовать последнюю версию на этом сайте.

...