Показать статистику
0 голосов
от (560 баллов)

Я на Ubuntu 20.04, и независимо от того, что я пытаюсь, я продолжаю получать ошибку сломанного пакета, и я даже не знаю, какие пакеты сломаны. У меня установлено основное Wine, но стабильная версия winehq мне не подходит. Dev ветка тоже не устанавливается.

Вот политика apt-cache wine-devel

wine-devel:
  Installed: (none)
  Candidate: 7.0.0~hirsute-2
  Version table:
     7.0.0~hirsute-2 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0.0~focal-2 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     7.0~rc6~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0~rc6~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     7.0~rc5~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0~rc5~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     7.0~rc4~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0~rc4~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     7.0~rc3~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0~rc3~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     7.0~rc2~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0~rc2~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     7.0~rc1~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     7.0~rc1~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.23~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.23~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.22~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.22~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.21~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.21~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.20~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.20~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.19~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.19~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.18~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.18~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.17~hirsute-2 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.17~focal-2 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.16~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.16~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.15~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.15~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.14~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.14~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.13~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.13~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.12~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.12~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.11~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.11~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.10~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.10~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.9~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.9~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.8~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.8~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.7~hirsute-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu hirsute/main amd64 Packages
     6.7~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.6~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.5~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.4~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.3~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.2~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.1~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0.0~focal-1 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0~rc6~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0~rc5~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0~rc4~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0~rc3~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0~rc2~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     6.0~rc1~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.22~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.21~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.20~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.19~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.18~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.17~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.16~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.15~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.14~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
     5.13~focal 500
        500 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages
...

Ну вот, спасибо. Всякий раз, когда я пробовал sudo apt install wine-devel=7.0.0~hirsute-2, это происходило.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-devel : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.2 is to be installed
              Depends: wine-devel-i386 (= 7.0.0~hirsute-2)
              Depends: wine-devel-amd64 (= 7.0.0~hirsute-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Итак, это политика apt-cache libc6.

https://1drv.ms/w/s!AhyzFTrGSyE4ozMYQB4LGaSCj2nE?e=h78giy

502 просмотров 1 ответов

1 Ответ

0 голосов
от (26.4тыс. баллов)

Два 404 репозитория  должны быть удалены из системы сначала путем

sudo add-apt-repository --remove ppa:ubuntu-wine/ppa
sudo add-apt-repository --remove ppa:cybolic/vineyard-testing
sudo apt-get update

Тогда с сожалением сообщаю, но разработчики WineHQ снова сломали репозитории . Я только что протестировал Ubuntu 20.04 LTS и 21.10 в новых контейнерах Docker, и я не могу установить ни один из них winehq-stablewinehq-devel и winehq-staging здесь.

Таким образом, вы должны удалить эти проблемные репозитории с помощью

sudo add-apt-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main'
sudo add-apt-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ hirsute main'
sudo add-apt-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ impish main'

Затем запустите, 

sudo apt-get update

а затем установите вино с помощью

sudo apt-get install wine

Или лучше - PlayOnLinux от

sudo apt-get install playonlinux

Затем установите какое-нибудь приложение с помощью мастера PlayOnLinux, а затем измените нужную версию Wine на нужное application/wine-prefix только для текущего пользователя. Чтобы управлять версиями Wine в PlayOnLinux, перейдите в меню « Инструменты » → « Управление версией Wine » и выберите доступные версии Wine здесь:

PlayOnLinux, версии Wine

...