Показать статистику
0 голосов
от (2.5тыс. баллов)

Я впервые пробую установить Wine, чтобы играть в свои игры, но у меня возникают ошибки, и я не знаю, как их исправить :  Пожалуйста, помогите мне, я не хочу возвращаться к виндоуз

$ sudo apt-get install wine-staging
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 wine-staging : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.2 is to be installed
                Depends: wine-staging-i386 (= 7.1~impish-1)
                Depends: wine-staging-amd64 (= 7.1~impish-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

и если я попытаюсь ввести:

$ sudo apt-get install wine-staging-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 wine-staging-i386:i386 : Depends: libc6:i386 (>= 2.34) but 2.31-0ubuntu9.2 is to be installed
                          Depends: libldap-2.5-0:i386 (>= 2.5.4) but it is not installable
                          Depends: libvkd3d1:i386 (>= 1.2~impish-1) but it is not going to be installed
                          Recommends: libcairo2:i386 but it is not going to be installed
                          Recommends: libcups2:i386 but it is not going to be installed
                          Recommends: libglu1-mesa:i386 but it is not going to be installed or
                                      libglu1:i386
                          Recommends: libgtk-3-0:i386 but it is not going to be installed
                          Recommends: libodbc1:i386 but it is not going to be installed
                          Recommends: libosmesa6:i386 but it is not going to be installed
                          Recommends: libsdl2-2.0-0:i386 but it is not going to be installed
                          Recommends: libv4l-0:i386 but it is not going to be installed
                          Recommends: libva-drm2:i386 but it is not going to be installed or
                                      libva-drm1:i386 but it is not installable
                          Recommends: libva-x11-2:i386 but it is not going to be installed or
                                      libva-x11-1:i386 but it is not installable
                          Recommends: libva2:i386 but it is not going to be installed or
                                      libva1:i386 but it is not installable
                          Recommends: libxcomposite1:i386 but it is not going to be installed
                          Recommends: libxcursor1:i386 but it is not going to be installed
                          Recommends: libxfixes3:i386 but it is not going to be installed
                          Recommends: libxi6:i386 but it is not going to be installed
                          Recommends: libxinerama1:i386 but it is not going to be installed
                          Recommends: libxrandr2:i386 but it is not going to be installed
                          Recommends: libxrender1:i386 but it is not going to be installed
                          Recommends: libxxf86vm1:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Может ли кто-нибудь помочь мне исправить то, что все в сети говорят использовать команду 

sudo apt-get install, но она не работает, и я не знаю, как это исправить.

 

 я использую Ubuntu 20.4, и нет никаких ошибок при обновлении.

399 просмотров 1 ответов

1 Ответ

0 голосов
от (26.4тыс. баллов)

Вы должны знать, что кодовое имя Ubuntu 20.04 LTS является фокусным , а не озорным . Последнее является кодовым названием Ubuntu 21.10, которое не является вашей версией.

Итак, вам нужно открыть терминал и использовать следующие команды:

sudo add-apt-repository -r -n 'deb https://dl.winehq.org/wine-builds/ubuntu/ impish main'

sudo dpkg --add-architecture i386 
cd /tmp
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key

sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main'
sudo apt-get update
sudo apt-get install winehq-stable

Также вас может заинтересовать установка утилиты PlayOnLinux 

sudo apt-get install playonlinux 

для установки Windows игр и приложений с помощью готовых и протестированных скриптов/мастеров .


...