Показать статистику
0 голосов
от (1.6тыс. баллов)

Попытка обновить пакеты 18.04, работающая на экземпляре AWS ec2, и получение следующей ошибки.

The package linux-aws-5.4-headers-5.4.0-1030 needs to be reinstalled, but I can't find an archive for it.

Я пробовал apt dist-upgradeapt-get install --fix-missing и dpkg --configure -a. Все это приводит к той же ошибке, что и выше. Пакет linux-aws-5.4-headers-5.4.0-1030 не указан в пакетах программного обеспечения для 18.04.

Заранее благодарю за любую помощь в решении этой проблемы.

150 просмотров 0 ответов
от (1.6тыс. баллов)
0

Разобрался с этим. Запустил следующее по порядку и решил проблему.

sudo dpkg --remove --force-remove-reinstreq linux-aws-5.4-headers-5.4.0-1030
sudo apt-get update
sudo apt-get upgrade (this will throw an unmet dependencies error)
sudo apt --fix-broken install

Пожалуйста, войдите или зарегистрируйтесь чтобы ответить на этот вопрос.

...