Показать статистику
0 голосов
от (2.5тыс. баллов)

Кажется, я столкнулся с ошибкой рабочего процесса с окончанием жизненного цикла Ubuntu. Я получаю скриншот ниже. Поэтому я нажимаю Обновить..., чтобы обновить его, но ничего не происходит.

Сообщение программы обновления программного обеспечения: обновления программного обеспечения больше не предоставляются для Ubuntu 21.04.  Чтобы оставаться в безопасности, вам следует перейти на Ubuntu 21.10.

 

Я погуглил и увидел, что мне нужно запустить enter do-release-upgrade только для того, чтобы понять, что это в основном одно и то же.

christopherwork@Chris-Gaming-Linux:~$ do-release-upgrade
Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

Please install all available updates for your release before upgrading.

Похоже, когда я нажимаю Обновить… на самом деле выполняется do-release-upgrade, а затем молча закрывается? В любом случае это очень раздражает и кажется очевидной ошибкой, которую нужно исправить.

230 просмотров 1 ответов

1 Ответ

0 голосов
от (2.5тыс. баллов)

С очевидной ошибкой приходит очевидное исправление. Один из моих пакетов был задержан во время обновления

user@host:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libc++1
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

И apt dist-upgrade тоже не обновлялся.

user@host:~$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libc++1
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Его нужно было обновить, установив его.

user@host:~$ sudo apt install libc++1
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libc++1-12 libc++abi1-12
Suggested packages:
  clang
The following packages will be REMOVED:
  libc++1-11 libc++abi1-11
The following NEW packages will be installed:
  libc++1-12 libc++abi1-12
The following packages will be upgraded:
  libc++1
1 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Need to get 264 kB of archives.
After this operation, 25.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y

После этого do-release-upgrade заработал.

от (2.7тыс. баллов)
0

Ряд пакетов находился в -предложенном репозитории, ожидая своих 7 дней, прежде чем попасть в -обновления.. однако EOL превзошел их... это была непредвиденная проблема ( исправления не следует загружать, если они находятся в течение 7 дней после EOL, чтобы избежать это ), создавая проблемы, которые в идеале будут уникальными для 21.04 . Ваша проблема в том, что вы должны были обновить выпуск до EOL, и вы получили бы исправления в 21.10 до того, как была достигнута дата EOL


...