Показать статистику
0 голосов
от (3.1тыс. баллов)

Имеется ноутбук ASUS ZenBook UX301 с установленной Ubuntu 19.10 (собираюсь выполнить обновление на 20.04). Есть такая проблема - при включенном xHCI (который активирует режим USB 3.0) отказывается работать Bluetooth. Если я пытаюсь включить Bluetooth штатными средствами (нажимаю на иконке Bluetooth и далее выбираю "Настройки Bluetooth"), то после включения Bluetooth получаю такое сообщение на первой консоли (видно в dmesg, если нажать Ctrl + Alt + F1 или если запустить терминал и посмотреть dmesg.log): 

[  948.641625] usb 1-4: USB disconnect, device number 2
[  948.912013] usb 1-4: new full-speed USB device number 5 using xhci_hcd
[  949.041299] usb 1-4: New USB device found, idVendor=8087, idProduct=07dc
[  949.041305] usb 1-4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[  949.055380] Bluetooth: hci0: read Intel version: 370710018002030d00
[  949.057370] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq
[  949.233672] Bluetooth: hci0: Intel Bluetooth firmware patch completed and activated

После этого, значок включения-выключения Bluetooth сразу переходит в выключенное положение. 

Несколько слов о моей системе:

  • Ноутбук Asus UX301LA
  • Беспроводной и bluetooth интерфейсы основаны на чипсете Intel 7260
  • Ubuntu 19.10 с последними обновлениями
Мне удалось заставить Bluetooth работать, выключив в настройках BIOS опцию "xHCI". Как известно, эта опция отвечает за скоростные режимы работы USB, т.к. USB 3.0 с выключенным xHCI становится медленным USB 1.1.
Так же когда эта опция выключена, нет возможности включать и выключать wifi (не работает переключение, хотя сам wifi активен). И, более того, после перезагрузки эта опция снова включается.
 
Кто подскажет как решить эту проблему?
29 просмотров 1 ответов

1 Ответ

0 голосов
от (2.7тыс. баллов)

У меня знакомый живет в Одессе и удалось решить эту проблему, заменив сам адаптер Bluetooth и Wifi на чипсете (у него тоже Intel 7260). То есть по сути проблема оказалась не с операционной системой, а пришлось обращаться в ремонт компьютеров. По ссылке можно перейти на сайт сервисного центра ИТСА, который помог решить проблему - если вы находитесь в Одессе, то рекомендую. 

Что бы дотянуть до замены железа (пока вы не отдали ноутбук в ремонт), попробуйте выставить такие настройки в опциях USB в BIOS:

Legacy USB support
USB 3.0 support
XHCI Hand-off
EHCI Hand-off

Если ваш BIOS позволяет выполнить более детальтные настройки серверного и южного моста материнской платы, тогда попытайтесь сделать так:

  • Включите режим XHCI
  • Отключите USB2 Link Power Management
  • Отключите  USB 2.0 (EHCI) Support

Если эти вещи успеха не принесли, попробуйте убедиться что прошивка Bluetooth загружается не слишком рано (может быть система пытается активизировать контроллер до того как сама прошивка получает доступ к нужным драйверам). Для этого откройте терминал и выполните: 

echo "blastlist btusb" | sudo tee /etc/modprobe.d/btusb.conf 

Далее, перезагрузите систему и после перезагрузки в консоли (или в терминале) выполните: 

sudo modprobe btusb

Если же и это не помогло, тогда удалите созданный конфиг что бы не засорять систему: 

sudo rm /etc/modprobe.d/btusb.conf

И все таки обращайтесь в сервисный центр. Опять же, если вы находитесь в Одессе, рекомендую сервисный центр ИТСА. Ребята из этого сервиса так же разбираются в Linux, при необходимости помогут настроить вам Bluetooth и убедиться что после замены чипсета все работает как ожидается. У них так же имеется прикольный видос по замене северного моста на ноуте - хорошая демонстрация уровня знания железа.

...