Показать статистику
0 голосов
от (2.3тыс. баллов)

Пробую установить deluge через менеджер пакетов synaptic и получаю такую ошибку: 

deluge:
 Depends: python-libtorrent but it is not going to be installed

Я попытался переустановить python-libtorrent, но получил еще одну проблему: 

The following packages have unmet dependencies:
 python-libtorrent : Depends: libtorrent-rasterbar6 (= 0.15.7-1) but 0.15.9+svn.r6292-0ubuntu1~natty is to be installed

Как же все-таки поставить deluge

82 просмотров 1 ответов

1 Ответ

0 голосов
от (15.2тыс. баллов)

Попробуйте такой алгоритм действий. Если libtorrent-rasterbar6 уже установлен, переустановите его: 

sudo apt-get install --reinstall libtorrent-rasterbar6

Если такого пакета не было (ставим в первый раз), тогда: 

sudo apt-get install libtorrent-rasterbar6

Далее, ставим python-libtorrent:

sudo apt-get install python-libtorrent

И напоследок  выполняем установку искомого пакета: 

sudo apt-get install deluge
от (3.8тыс. баллов)
0

У меня получилось другим способом решить аналогичную проблему:

sudo add-apt-repository ppa:libtorrent.org/rc-1.1-daily
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install python3-libtorrent
sudo apt-get install deluge
...