Показать статистику
0 голосов
от (300 баллов)
Уважаемые знатоки, скажите, кто знает, можно ли как-то Убунте запретить делать апгрейд версии пакетов и файлов загрузки при операциях mkinitramfs, apt?

Мне нужно всегда оставаться только в той версии, с которой установился.
440 просмотров 2 ответов

2 Ответы

0 голосов
от (380 баллов)
Нужно использовать aptitude hold, но всё равно все операции с  пакетами придётся делать через aptitude. По-другому пока что я не вижу, как можно это сделать.
0 голосов
от (17.4тыс. баллов)

Есть разные способы. Вот пара примеров

sudo apt-mark hold <имя_пакета>

Удалить холд (позволить пакету снова обновляться):

sudo apt-mark unhold <имя_пакета>

Еще можно так:

echo "<package-name> hold" | sudo dpkg --set-selections

Убрать холд:

echo "<package-name> install" | sudo dpkg --set-selections

Еще вариант - установить менеджер synaptic и выбрать холд там.

sudo install synaptic using sudo apt-get install synaptic

Далее запустить менеджер так:

gksudo synaptic 

И выбрать пакет, где нужно поставить холд:


...