Показать статистику
0 голосов
от (340 баллов)

Сама ошибка выглядит так:

dpkg: предупреждение: анализ файла «/var/lib/dpkg/status» около строки 43498 пакета «qtdeclarative5-accounts-plugin:amd64»: в значении поля «Homepage» обнаружена пустая строка
dpkg: ошибка: анализ файла «/var/lib/dpkg/status» около строки 43500 пакета «qtdeclarative5-accounts-plugin:amd64»: значение поля «Package» должно встречаться только один раз
E: Sub-process /usr/bin/dpkg returned an error code (2)

Пробывал чуть ли не все популярные решения, которые есть в сети и не один не помог, а именно:

dpkg --clear-avail
apt-get clean
apt-get update
apt-get install -f
cp /var/lib/dpkg/status-old /var/lib/dpkg/status

Ручками пробывал но проблема в том что переходя на эти строки, к примеру туже 43498 где пишет что homepage пустая строка, но на самом деле если перейти на 43498 строку то homepage вовсе не пустой.

43498 строка:

код:

Homepage: https://launchpad.net/accounts-qml-module

полностью:

Package: qtdeclarative5-accounts-plugin
Status: install ok installed
Priority: optional
Section: oldlibs
Installed-Size: 10
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: accounts-qml-module
Version: 0.6+17.04.20170405-0ubuntu1
Depends: qml-module-ubuntu-onlineaccounts
Description: transitional dummy package for Online Accounts QML clients
 This module provides access to the Online Accounts framework from QML
 applications.
Homepage: https://launchpad.net/accounts-qml-module
43500 строка:
Package: libkmldom1
Package: libkmldom1
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 876
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Multi-Arch: same
Source: libkml
Version: 1.3.0-4
Depends: libc6 (>= 2.14), libexpat1 (>= 2.0.1), libgcc1 (>= 1:3.0), libkmlbase1 (>= 1.3.0~r864), libstdc++6 (>= 5.2)
Description: Library to manipulate KML 2.2 OGC standard files - libkmldom
 This is a library for use with applications that want to parse,
 generate and operate on KML, a geo-data XML variant. It is an
 implementation of the OGC KML 2.2 standard. It is written in C++ and
 bindings are available via SWIG to Java and Python.
 This package contains the libkmldom shared library.
Original-Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
Homepage: https://github.com/libkml/libkml
723 просмотров 1 ответов

1 Ответ

0 голосов
от (540 баллов)

В принципе я думаю, что можно смело удалить всю эту строку

Homepage:.......

у половины пакетов ее  нет, но сначала сделайте бэкап файла.

И еще -- посмотрите пожалуйста

ls -l /var/backups/

дату последнего бэкапа status

Можно попробовать всё это дело как раз восстановить из бекапов.

...