Показать статистику
0 голосов
от (170 баллов)
На одном из своих ноутбуков пытаюсь обновить linux mint и пишет что не может обновиться и что нужно исправлять ошибки в пакетах или что есть там ошибки. Что мне делать? Попытка обновления проходит неудачно в который раз. Кто сталкивался?
319 просмотров 3 ответов

3 Ответы

0 голосов
от (580 баллов)
Может быть вам перейти на debian, так как у них система управления пакетами намного лучше. Вы подумайте над этим вариантом, возможно вам и подойдет.
0 голосов
от (920 баллов)
Удалить и установить по-новой. Можно делать и бэкап а потом уже работать с другими пакетами, а не с теми которые стали причиной проблем при обновлении.
0 голосов
от (250 баллов)

Было бы очень полезно увидеть вывод вашего термина, о каких именно ошибках в каких пакетах он пишет, когда вы пытаетесь обновиться. Могу предположить, что при одном из предыдущих обновлений произошел сбой, например - обрыв интернета - и у вас теперь есть пакеты с неудовлетворенными зависимостями или даже просто недокачанные. Для начала попробуйте введсти эти 2 команды -

sudo apt-get update

а потом:

sudo apt-get upgrade -f

Apt - умница, он перекачает и переустановит ваши битые пакеты и недокачанные зависимости.
Кроме того, можно легко переустановить пакеты через Synaptic (если у вас его нет, установите его строкой

sudo apt-get install synaptic

и запустите с вашим паролем.
Обновите, нажав CTRL+R или кнопку "Обновить" на верхней панели, чтобы скачался список последних доступных версий всех ваших установленных пакетов. Сверху есть меню "Правка", в ней найдите "Исправить пакеты с ошибками", нажмите CTRL+P (или выберите "Внести отмеченные изменения). Обязательно нажмите потом кнопку "Применить" на верхней панели Синаптика.
Кроме того, ошибки, о которых вы говорите, могут быть связаны с несовместимостью версий пакетов, особенно если вы обновляли свою Минт то командой upgrade, то командой dist-upgrade, то встроенной графической обновлялкой, или лазали в системные папки терминалом с правами рута, или качали с каких-нибудь сайтов что-нибудь с расширением deb и устанавливали это... Но тут рецепт решения нужно искать индивидуально.

...